Announcement

Collapse
No announcement yet.

https directing to different location than http

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • https directing to different location than http

    Hi All,


    Fairly new to VPS, so looking for a bit of help on an issue that I believe to be possibly DNS related.



    I've recently setup a new VPS as server1.mydomain.com, cpanel is installed and I have a SSL cert so my cpanel, webmail, WHM etc are all SSL secure with no warnings etc...


    I have now added mydomain.com as an account in WHM and installed Wordpress as http://www.mydomain.com and all was working fine.


    I am now trying to make what's currently http://www.mydomain.com work as https://www.mydomain.com so that's also covered by my SSL cert, but when I go to https://www.mydomain.com it takes me to the same page as what I'd go to if I typed https://server1.mydomain.com into the address bar.


    Has anyone any ideas why? I'm assuming it's something I've done wrong as this is my first VPS. I've had https working on my shared hosting in the past, but I'm aware this is a little different



    Any help appreciated!
    Thanks in advance!



    Grant

  • #2
    Ah - If I go to any of the sites hosted on my VPS via https, I'm taken to the server1.mydomain.com page... so I'm guessing it's most likely configuration in WHM?

    Comment


    • #3
      Have you installed the SSL certificate either in WHM or cPanel and set up the SSL host?
      GoDaddy are abusing WHC with shill advertising

      Comment


      • #4
        Thanks for the reply!

        I'd only installed the cert as a service certificate, so it was only active for cPanel etc

        I've now installed it onto my domain from under the SSL/TLS section of WHM and it works
        Last edited by gtg93; 14th June 2015, 06:26 PM.

        Comment


        • #5
          Hi,

          You may also need to adjust the setting for "When visiting /cpanel or /whm or /webmail with SSL, you can choose to redirect to" in Main >> Server Configuration >> Tweak Settings. Select either "SSL certificate name" or "Hostname" to avoid seeing a browser pop-up about a domain-name mismatch when accessing these services.

          Thank you,
          ----
          Aaron Brad

          Comment


          • #6
            Originally posted by aaronbrad View Post
            Hi,

            You may also need to adjust the setting for "When visiting /cpanel or /whm or /webmail with SSL, you can choose to redirect to" in Main >> Server Configuration >> Tweak Settings. Select either "SSL certificate name" or "Hostname" to avoid seeing a browser pop-up about a domain-name mismatch when accessing these services.

            Thank you,
            Did you actually read the question? Or the rest of the thread for that matter where you would have seen that this was answered and the OP's problem solved several months ago?
            GoDaddy are abusing WHC with shill advertising

            Comment

            Working...
            X